Packages installed with ThoughtSpot for RHEL and OEL

To successfully deploy ThoughtSpot in your organization, you must have the following packages on each node of your ThoughtSpot cluster: yum, python 3, and R. ThoughtSpot does not install the R packages if you define the skip_r flag in the Ansible playbook. When the Ansible playbook runs, it automatically installs them.

ThoughtSpot also uses the third-party software packages listed in Third-party software.

If your organization requires that privilege escalation take place through an external tool that integrates with Ansible, you must install the packages yourself. The Ansible playbook does not install them. Refer to Install ThoughtSpot using Ansible on clusters that use RHEL.
Yum RPM packages for RHEL 7.8 and 7.9 and OEL 7.9
Package

Minimum Version

aide

0.15.1-13.el7

alsa-lib

1.1.8-1.el7

amcheck_next11

1.5-1.rhel7

at

3.1.13-24.el7

atk.x86_64

2.28.1-1.el7

atop

2.4.0-4.el7

azure-cli

2.0.81-1.el7

bind-utils

32:9.11.4-9.P2.el7

cmake

2.8.12.2-2.el7

cryptsetup

2.0.3-5.el7

cups-libs.x86_64

1:1.6.3-40.el7

curl

7.29.0-54.el7_7.2

cyrus-sasl

2.1.26-23.el7

cyrus-sasl-devel

2.1.26-23.el7

cyrus-sasl-plain

2.1.26-23.el7

dkms

2.7.1-1.el7

dmidecode

1:3.2-3.el7

ethtool

2:4.8-10.el7

fio

3.7-1.el7

gcc

4.8.5-39.el7

gcc-c++

4.8.5-44.el7

GConf2.x86_64

3.2.6-8.el7

glib2

2.56.1-5.el7

glibc-devel

2.17-292.el7

google-cloud-sdk

282.0.0-1. Only for customers running on GCP

graphviz

2.30.1-21.el7

gtk3.x86_64

3.22.30-3.el7

http-parser

2.7.1-8.el7

httpd-tools

2.4.6-90.el7

ipa-gothic-fonts

003.03-5.el7

iperf3

3.1.7-2.el7

ipmitool

1.8.18-7.el7

libcap

2.22-10.el7

libcgroup-tools

0.41-21.el7

libcurl-devel

7.29.0-54.el7_7.2

libdrm

2.4.97-2.el7

libffi-devel

3.0.13-18.el7

libgit2-devel

0.26.6-1.el7. Not for AL2, only for RHEL7, RHEL8, and OEL

libtool

2.4.2-22.el7_3

libXcomposite.x86_64

0.4.4-4.1.el7

libXcursor.x86_64

1.1.15-1.el7

libXdamage.x86_64

1.1.4-4.1.el7

libXext.x86_64

1.3.3-3.el7

libXi.x86_64

1.7.9-1.el7

libxml2-devel

2.9.1-6.el7_2.3

libXrandr.x86_64

1.5.1-2.el7

libXScrnSaver.x86_64

1.2.2-6.1.el7

libXtst.x86_64

1.2.3-1.el7

lsof

4.87-6.el7

lsscsi

0.27-6.el7

lynx

2.8.8-0.3.dev15.el7

mesa-libgbm

18.3.4-10.el7

mutt

5:1.5.21-28.el7_5

nc

2:6.40-19.el7

net-tools

2.0-0.25.20131004git.el7

NLOpt

2.4.2-2.el7

NLOpt-devel

2.4.2-2.el7

ntp

4.2.6p5-29.el7

open-vm-tools

10.3.0-2.el7_7.1

openldap-clients

2.4.44-21.el7_6

openldap-devel

2.4.44-21.el7_6

openssh

7.4p1-21.el7

openssh-clients

7.4p1-21.el7

openssl-devel

1:1.0.2k-19.el7

pango.x86_64

1.42.4-4.el7_7

parted

3.1-31.el7

pciutils

3.5.1-3.el7

pigz

2.3.4-1.el7

postfix

2:2.10.1-7.el7

postgresql11-contrib

11.11-1PGDG.rhel7

postgresql11-devel

11.11-1PGDG.rhel7

postgresql11-libs

11.11-1PGDG.rhel7

postgresql11-server

11.11-1PGDG.rhel7

postgresql13-contrib

13.9-1PGDG.rhel7

postgresql13-devel

13.9-1PGDG.rhel7

postgresql13-libs

13.9-1PGDG.rhel7

postgresql13-server

13.9-1PGDG.rhel7

psmisc

22.20-16.el7

python-devel

2.7.5-86.el7

python-pyasn1

0.1.6-2.el7

python2-cryptography

1.7.2-2.el7

python3

3.6.8-10.el7.

python3-devel

3.6.8-10.el7.

R

3.6.0-1.el7

R-devel

3.6.0-1.el7

rsync

3.1.2-10.el7

rsyslog

8.24.0-41.el7_7.2

samba-client

4.9.1-10.el7_7

screen

4.1.0-0.25.20120314git3c2946.el7

sg3_utils

1.37-18.el7_7.2

snappy-devel

1.1.0-3.el7

strace

4.12-9.el7

strongswan

5.7.2-1.el7

sysstat

10.1.5-18.el7

telnet

1:0.17-64.el7

tinyproxy

1:8.5.13-6.el7

tmux

1.8-4.el7

unzip

6.0-20.el7

util-linux

2.23.2-61.el7_7.1

uuid

1.6.2-26.el7. Not for AL2, only for RHEL7, RHEL8, and OEL

vim

2:7.4.629-6.el7

vnc-server

1.8.0-17.el7

wget

1.14-18.el7_6.1

xorg-x11-fonts-100dpi

7.5-9.el7

xorg-x11-fonts-75dpi

7.5-9.el7

xorg-x11-fonts-cyrillic

7.5-9.el7

xorg-x11-fonts-misc

7.5-9.el7

xorg-x11-fonts-Type1

7.5-9.el7

xorg-x11-utils

7.7-20.el7

yum-plugin-versionlock

1.1.31-52.el7

zip

3.0-11.el7

zsh

5.0.2-33.el7. Not for AL2, only for RHEL7, RHEL8, and OEL

Yum RPM packages for RHEL 8.1 - 8.7
Package

Minimum Version

GConf2

3.2.6-22.el8

R

4.1.2-1.el8

R-devel

4.1.2-1.el8

aide

0.16-14.el8

alsa-lib

1.2.5-4.el8

amcheck_next11

1.5-1.rhel8

at

3.1.20-11.el8

atk

2.28.1-1.el8

atop

2.7.1-1.el8

bind-utils

32:9.11.26-6.el8

cmake

3.20.2-4.el8

compat-openssl10

1:1.0.2o-4.el8_6

cryptsetup

2.3.3-4.el8

csnappy-devel

0-16.20181121git973f62f.el8

cups-libs

1:2.2.6-40.el8

curl

7.61.1-22.el8

cyrus-sasl

2.1.27-5.el8

cyrus-sasl-devel

2.1.27-5.el8

cyrus-sasl-plain

2.1.27-5.el8

dkms

3.0.3-1.el8

dmidecode

1:3.2-10.el8

ethtool

2:5.8-7.el8

fio

3.19-3.el8

gcc

8.5.0-4.el8_5

gcc-c++

8.5.0-16.el8_7

git

2.27.0-1.el8

glib2

2.56.4-156.el8

glibc-devel

2.28-164.el8

graphviz

2.40.1-43.el8

gtk3

3.22.30-8.el8

http-parser

2.8.0-9.el8

httpd-tools

2.4.37-43.module+el8.5.0+13806+b30d9eec.1

ipa-gothic-fonts

003.03-15.el8

iperf3

3.5-6.el8

ipmitool

1.8.18-18.el8

iptables

1.8.4-20.el8

libXScrnSaver

1.2.3-1.el8

libXcomposite

0.4.4-14.el8

libXcursor

1.1.15-3.el8

libXdamage

1.1.4-14.el8

libXext

1.3.4-1.el8

libXi

1.7.10-1.el8

libXrandr

1.5.2-1.el8

libXtst

1.2.3-7.el8

libcap

2.26-5.el8

libcgroup-tools

0.41-19.el8

libcurl-devel

7.61.1-22.el8

libffi-devel

3.1-22.el8

libgit2-devel

0.26.8-2.el8

libtool

2.4.6-25.el8

libxml2-devel

2.9.7-9.el8_4.2

lsof

4.93.2-1.el8

lsscsi

0.32-3.el8

lynx

2.8.9-2.el8

mesa-libgbm

22.1.5-2.el8

mutt

2.0.7-2.el8

net-tools

2.0-0.52.20160912git.el8

openldap-clients

2.4.46-18.el8

openldap-devel

2.4.46-18.el8

openssh

8.0p1-10.el8

openssh-clients

8.0p1-10.el8

openssl-devel

1:1.1.1k-5.el8_5

pango

1.42.4-8.el8

parted

3.2-39.el8

pciutils

3.7.0-1.el8

pigz

2.4-4.el8

policycoreutils-python-utils

2.9-16.el8

postfix

2:3.5.8-2.el8

postgresql11-contrib

11.14-1PGDG.rhel8

postgresql11-devel

11.14-1PGDG.rhel8

postgresql11-libs

11.14-1PGDG.rhel8

postgresql11-server

11.14-1PGDG.rhel8

postgresql13-*

13.9-1PGDG.rhel8

psmisc

23.1-5.el8

python3-pyasn1

0.3.7-6.el8

python36-devel

3.6.8-38.module+el8.5.0+12207+5c5719bc

rsync

3.1.3-19.el8_7.1

rsyslog

8.2102.0-5.el8

samba-client

4.14.5-7.el8_5

screen

4.6.2-12.el8

sg3_utils

1.44-5.el8

snappy-devel

1.1.8-3.el8

strace

5.7-3.el8

strongswan

5.9.4-2.el8

sysstat

11.7.3-6.el8

telnet

1:0.17-76.el8

tmux

2.7-1.el8

unzip

6.0-45.el8_4

util-linux

2.32.1-28.el8

uuid

1.6.2-43.el8

vim

8.0.1763-19.el8_6.4

wget

1.19.5-10.el8

xorg-x11-fonts-100dpi

7.5-19.el8

xorg-x11-fonts-75dpi

7.5-19.el8

xorg-x11-fonts-Type1

7.5-19.el8

xorg-x11-fonts-cyrillic

7.5-19.el8

xorg-x11-fonts-misc

7.5-19.el8

xorg-x11-utils

7.5-28.el8

zip

3.0-23.el8

zsh

5.5.1-6.el8_1.2

Python 3 packages
Package

Required Version

ansible

4.10.0 only

awscli

1.24.10 only

azure-cli

2.39.0 only

boto3

1.23.10 only

botocore

1.26.10 only

bs4

0.0.1 only

celery

5.2.7 only; only use with Python version 3.9 or later

certifi

2022.6.15 only

chardet

3.0.4 only

Click

8.0.4 only

cmdstanpy

latest version; only use with Python version 3.9 or later

colorama

0.4.4 only

configobj

5.0.7 only

convertdate

2.1.2 or later; only use with Python version 3.9 or later

cryptography

3.3.1 only

Cython

0.22 or later; only use with Python version 3.9 or later

dnspython

2.2.1 only

egnyte

0.5.3 only

enum34

1.1.10 only

eventlet

0.33.1 only

fastapi

0.79.0 only; only use with Python version 3.9 or later

gevent

21.12.0 only

gunicorn

20.1.0 only; only use with Python version 3.9 or later

holidays

0.11.3.1 or later; only use with Python version 3.9 or later

idna

3.3 only

influxdb

5.3.1 only

ipython

7.16.3 only

itsdangerous

2.0.1 only

Jinja2

3.0.3 only

kombu

5.2.4 only; only use with Python version 3.9 or later

locust

2.8.6 only

LunarCalendar

0.0.9 or later; only use with Python version 3.9 or later

matplotlib

2.0.0 or later

mockito

1.3.3 only; only use with Python version 3.9 or later

numpy

1.19.5 only; only use with Python version 3.9 or earlier

numpy

1.22.4 only; only use with Python version 3.9 or later

openpyxl

3.0.10 only

pandas

1.1.5 only; only use with Python version 3.9 or earlier

pandas

1.4.3 only; only use with Python version 3.9 or later

paramiko

2.11.0 only

pexpect

4.8.0 only

prometheus-client

0.14.1 only; only use with Python version 3.9 or later

prometheus-fastapi-instrumentator

5.8.2 only; only use with Python version 3.9 or later

prompt-toolkit

3.0.30 only

prophet

1.1 or later; only use with Python version 3.9 or later

psutil

5.9.1 only

psycopg2

2.9.4 only

pycryptodome

3.15.0 only

pyparsing

3.0.9 only

python-dateutil

2.8.2 only

python-gflags

3.1.2 only

python-ldap

3.4.2 only

python-slugify

6.1.2 only

pytz

2022.2.1 only

redis

4.3.4 only; only use with Python version 3.9 or later

requests

2.27.1 only

ruamel.yaml

0.17.21 only

setuptools-git

1.2 or later; only use with Python version 3.9 or later

setuptools

42 or later

setuptools

42 or later; only use with Python version 3.9 or later

six

1.16.0 only

sktime[all_extras]

0.13.0 only; only use with Python version 3.9 or later

SQLAlchemy

1.4.40 only

toml

0.10.2 only

tqdm

4.36.1 or later; only use with Python version 3.9 or later

types-protobuf

3.19.22 only; only use with Python version 3.9 or later

tzlocal

4.2 only; only use with Python version 3.9 or later

urllib3

1.26.13 only

uvicorn[standard]

0.18.2 only; only use with Python version 3.9 or later

wheel

0.37.0 or later

R packages

ThoughtSpot does not install the R packages if you define the skip_r flag in the Ansible playbook.

Download: R RPM package list.

Package

Minimum Version

broom

0.7.9

EnvStats

2.4.0

forecast

8.15

ggplot2

3.3.5

ggpubr

0.4.0

import

1.2.0

leaps

3.1

locfit

1.5-9.4

lubridate

1.8.0

magrittr

2.0.1

padr

0.6.0

Rserve

1.7.3.1

timetk

2.6.1

TSA

1.2

tseries

0.10.48

xts

0.12.1